3.223.3.251

BGP vietnē Mikrotik

BGP vietnē Mikrotik

Iespējojiet IPv6 maršrutētājā

Pirmā lieta, ko mēs darīsim, ir iespējot IPv6 mūsu Mikrotik maršrutētājā

system package enable ipv6
system reboot 
y

Tādējādi dators tiks restartēts, un, kad tas atgriezīsies, tam būs jauna izvēlne ar nosaukumu IPv6

Mēs arī iestatīsim ilgāku ARP taimautu, lai būtu labs pilsonis, 4 stundas parasti ir diezgan piesardzīgs laiks, kas ļauj izvairīties no atjauninājumu sūtīšanas ik pēc 5 minūtēm..

/ip settings set arp-timeout=04:00:00

Definējiet savu IP tranzīta, Perú IX (PIT Peru sac) (pitperu.net) un iekšējā tīkla IPv4 un IPv6 adreses.

Pieņēmumi par piemēru:

• LACNIC piešķirtais ASN mūsu organizācijai ir AS 123456

• LACNIC piešķirtais IPv4 bloks ir100.100.100.0/22

• LACNIC piešķirtais IPv6 bloks ir 2803:cd10::/32.

• IPv4 adrese IP tranzīta nodrošinātāja no punkta uz punktu saitei198.51.100.2/30 (kur IP tranzīta nodrošinātāja pusē esošais aprīkojums, pret kuru mēs veiksim BGP, ir 198.51.100.1).

• IPv6 adrese IP tranzīta nodrošinātāja tiešai saiknei ::1)

• Perú IX (PIT Peru sac) (pitperu.net) piešķirtā IPv4 adrese ir45.183.47.254/24.

• Perú IX (PIT Peru sac) (pitperu.net) piešķirtā IPv6 adrese ir 2803:cd60:6411:5::ff/64.

Konfigurējiet LACNIC piešķirtās IPv4 un IPv6 adreses cilpas interfeisā

Vispirms ir jāizveido cilpas interfeiss un jāpiešķir to LACNIC piešķirtajām IPv4 un IPv6 adresēm. Vēl viena iespēja ir piešķirt IP citam interfeisam vai statisku maršrutu citam maršrutētājam.

/interface bridge add name=loopback
#change la 100.100.100.1/22 for the first IPv4 of the range assigned by LACNIC #
/ip address add address=100.100.100.1/22 interface=loopback 
#cambiar la 2803:cd10::/32 por la primera IPv6 del rango asignado por LACNIC#
/ipv6 address add address=2803:cd10::/32 advertise=no interface=loopback  

Pēc tam mēs definēsim IP tranzīta nodrošinātāja IPv4 un IPv6 adreses, ja tās ierīcē vēl nav definētas.:

#cambiar la 198.51.100.2/30 por la IPv4 otorgada por tu Proveedor de IP transit#
/ip address add address=198.51.100.2/30 interface=IP_TRANSIT
#cambiar la 2803:dd99:1111::2/126 por la IPv6 otorgada por tu Proveedor de IP transit#
/ipv6 address add address=2803:dd99:1111::2/126 advertise=no interface=IP_TRANSIT

Visbeidzot, mēs konfigurēsim Perú IX (PIT Peru sac) piešķirtās IP adreses.)

#cambiar la 45.183.47.254/24 por la IPv4 asignada por Perú IX (PIT Peru sac)#
/ip address add address=45.183.47.254/24 interface=PIT_PERU_sac 
#cambiar la 2803:cd60:6411:5::ff/64 por la IPv6 asignada por Perú IX (PIT Peru sac)#
/ipv6 address add address=2803:cd60:6411:5::ff/64 advertise=no interface=PIT_PERU_sac

Ievadiet savas organizācijas ASN (LACNIC piešķirtais ASN)

Mūsu piemērā mēs pieņemsim, ka LACNIC mums piešķīra ASN 123456, maršrutētāja ID mēs ievietosim savu pirmo publisko IPv4 adresi..

# change the name to the name you like, the ace to your ASN number granted by LACNIC and in route-id you can use the IP of the loopback or another #
/routing bgp instance add name=AS123456 as=123456 router-id=100.100.100.1

Izveidojiet maršrutēšanas filtrus OUT un IN ķēdēm

Pirms BGP sesiju sākšanas ir ĻOTI SVARĪGI izveidot drošības filtrus gan ievadei, gan izvadei.

Svarīgi: filtros faktoru secībai ir nozīme, katras ķēdes pirmais indekss vienmēr tiek apstrādāts pirmais.

IPv4 izvades filtri (OUT)

 #change the 100.100.100.0/22 with your prefix assigned by LACNIC #
 
/routing filter
add action=accept chain=IP_TRANSIT_IPv4_OUT prefix=100.100.100.0/22 prefix-length=22
add action=discard chain=IP_TRANSIT_IPv4_OUT
 
 
#change the 100.100.100.0/22 with your prefix assigned by LACNIC. It is important that we are going to send more specific prefixes to IX, in this case / 24s #
 
/routing filter
add action=accept chain=PIT_PERU_sac_IPv4_OUT prefix=100.100.100.0/22 prefix-length=22-24
add action=discard chain=PIT_PERU_sac_IPv4_OUT

IPv6 izvades filtri (OUT)

# change 2803: cd10 :: / 32 with your IPv6 prefix assigned by LACNIC #
 
/routing filter
add action=accept chain=IP_TRANSIT_IPv6_OUT prefix=2803:cd10::/32 prefix-length=32
add action=discard chain=IP_TRANSIT_IPv6_OUT
 
 
#change 2803: cd10 :: / 32 with your IPv6 prefix assigned by LACNIC. It is important that we will send more specific prefixes to IX, in this case / 48s #
 
/routing filter
add action=accept chain=PIT_PERU_sac_IPv6_OUT prefix=2803:cd10::/32 prefix-length=32-48
add action=discard chain=PIT_PERU_sac_IPv6_OUT

Kāpēc mēs reklamējam IP tranzīta nodrošinātāju / 22 (mazāk specifisks prefikss) un Perú IX (PIT Peru sac) daudzkārtni / 24 (precīzāk)?

Tas ir svarīgi, lai nodrošinātu, ka priekšroka tiek dota ceļam caur Peru IX (PIT Peru sac), nevis IP tranzītam, un tādējādi izvairītos no tā, ka datplūsma, kas varētu tikt apkalpota caur Peru IX (PIT Peru sac), tiek apkalpota, izmantojot IP tranzītu.

IPv4 ievades (IN) filtri

Šeit mums ir jāpieņem lēmums, vai lūdzam IP tranzīta nodrošinātājam nosūtīt mums tikai noklusējuma maršrutu vai arī mēs prasām DFZ (pilnu BGP tabulu bez noklusējuma maršruta, kas pazīstama arī kā Full BGP)

# we will only use this first line if we are accepting default route #
 
/routing filter
add action=accept chain=IP_TRANSIT_IPv4_IN prefix=0.0.0.0/0
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=45.183.47.0/24 prefix-length=24-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=10.0.0.0/8 prefix-length=8-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=100.64.0.0/10 prefix-length=10-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=127.0.0.0/8 prefix-length=8-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=169.254.0.0/16 prefix-length=16-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=172.16.0.0/12 prefix-length=12-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=192.0.8.0/24 prefix-length=24-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=192.88.99.0/24 prefix-length=24-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=192.168.0.0/16 prefix-length=16-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=198.18.0.0/15 prefix-length=15-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=198.51.0.0/24 prefix-length=24-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=203.0.113.0/24 prefix-length=24-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=224.0.0.0/4 prefix-length=4-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=240.0.0.0/4 prefix-length=4-32
add action=discard chain=IP_TRANSIT_IPv4_IN prefix=0.0.0.0/0 prefix-length=25-32
add action=accept chain=IP_TRANSIT_IPv4_IN
 
 
 
In the filters of the Perú IX (PIT Peru sac) chain we will also apply filters, although the Route Servers apply filters it is important to always apply filters anyway #
 
/routing filter
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=0.0.0.0/0
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=45.183.47.0/24 prefix-length=24-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=10.0.0.0/8 prefix-length=8-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=100.64.0.0/10 prefix-length=10-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=127.0.0.0/8 prefix-length=8-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=169.254.0.0/16 prefix-length=16-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=172.16.0.0/12 prefix-length=12-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=192.0.8.0/24 prefix-length=24-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=192.88.99.0/24 prefix-length=24-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=192.168.0.0/16 prefix-length=16-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=198.18.0.0/15 prefix-length=15-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=198.51.0.0/24 prefix-length=24-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=203.0.113.0/24 prefix-length=24-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=224.0.0.0/4 prefix-length=4-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=240.0.0.0/4 prefix-length=4-32
add action=discard chain=PIT_PERU_sac_IPv4_IN prefix=0.0.0.0/0 prefix-length=25-32
add action=accept chain=PIT_PERU_sac_IPv4_IN

Ieejas filtri (IN) IPv6

Šeit mums ir jāpieņem visi prefiksi, ko Perú IX (PIT Peru sac) mums sūta, izņemot tos, kas ir ieteicami labas prakses filtrēšanai.

# the first line will only be used if we accept the default path #
 
/routing filter
add action=accept chain=IP_TRANSIT_IPv6_IN prefix=::/0
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=100::/64 prefix-length=64-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=2001:2::/48 prefix-length=48-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=2001:10::/28 prefix-length=28-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=2001:db8::/32 prefix-length=32-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=2002::/16 prefix-length=16-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=3ffe::/16 prefix-length=16-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=fc00::/7 prefix-length=7-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=fe80::/10 prefix-length=10-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=fec0::/10 prefix-length=10-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=ff00::/8 prefix-length=8-128
add action=discard chain=IP_TRANSIT_IPv6_IN prefix=::/0 prefix-length=65-128
add action=accept chain=IP_TRANSIT_IPv6_IN
 
#In the filters of the Perú IX (PIT Peru sac) chain we will also apply filters, although the Route Servers apply filters it is important to always apply filters anyway #
/routing filter
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=::/0
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=100::/64 prefix-length=64-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=2001:2::/48 prefix-length=48-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=2001:10::/28 prefix-length=28-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=2001:db8::/32 prefix-length=32-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=2002::/16 prefix-length=16-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=3ffe::/16 prefix-length=16-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=fc00::/7 prefix-length=7-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=fe80::/10 prefix-length=10-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=fec0::/10 prefix-length=10-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=ff00::/8 prefix-length=8-128
add action=discard chain=PIT_PERU_sac_IPv6_IN prefix=::/0 prefix-length=65-128
add action=accept chain=PIT_PERU_sac_IPv6_IN

Izveidojiet BGP Peer ar savu IP tranzīta nodrošinātāju

Mūsu piemērā mūsu IP tranzīta nodrošinātājam ir ASN 1200, kas mūsu piemērā izmantos IP 198.51.100.1. Vērtība 1200 ir jāaizstāj ar jūsu IP tranzīta nodrošinātāja ASN un 198.51.100.1 ar tās vārtejas BGP IP, ko jums nodrošina jūsu IP tranzīta nodrošinātājs..

#Change the instance for the one that corresponds in your case, the same in the remote-address and remote-as #
/routing bgp peer add name=IP_TRANSIT_IPv4 instance=AS123456 remote-address=198.51.100.1 remote-as=1200 in-filter=IP_TRANSIT_IPv4_IN out-filter=IP_TRANSIT_IPv4_OUT remove-private-as=yes
#Change the instance for the one that corresponds in your case, the same in the remote-address and remote-as #
/routing bgp peer add name=IP_TRANSIT_IPv6 instance=AS123456 remote-address=2803:dd99:1111::1 remote-as=1200 in-filter=IP_TRANSIT_IPv6_IN out-filter=IP_TRANSIT_IPv6_OUT remove-private-as=yes address-families=ipv6

Izveidojiet BGP Peers, izmantojot Peru IX maršruta serverus (PIT Peru sac) (pitperu.net)

Šajā piemērā mēs konfigurēsim gan Peru IX maršruta serveri IPv4, gan IPv6 (PIT Peru sac), tas ir, RS1 un RS2, mūsu piemērā mums tika piešķirta BGP parole “peeringinperu”

/routing bgp peer add name=PIT_PERU_sac_RS1_IPv4 instance=AS123456 remote-address=45.183.47.1 remote-as=64115 tcp-md5-key=peeringinperu max-prefix-limit=12000 max-prefix-restart-time=360 in-filter=PIT_PERU_sac_IPv4_IN out-filter=PIT_PERU_sac_IPv4_OUT remove-private-as=yes
/routing bgp peer add name=PIT_PERU_sac_RS2_IPv4 instance=AS123456 remote-address=45.183.47.2 remote-as=64115 tcp-md5-key=peeringinperu max-prefix-limit=12000 max-prefix-restart-time=360 in-filter=PIT_PERU_sac_IPv4_IN out-filter=PIT_PERU_sac_IPv4_OUT remove-private-as=yes
 
/routing bgp peer add name=PIT_PERU_sac_RS1_IPv6 instance=AS123456 remote-address=2803:cd60:6411:5::1 remote-as=64115 tcp-md5-key=peeringinperu max-prefix-limit=12000 max-prefix-restart-time=360 in-filter=PIT_PERU_sac_IPv6_IN out-filter=PIT_PERU_sac_IPv6_OUT remove-private-as=yes address-families=ipv6
/routing bgp peer add name=PIT_PERU_sac_RS2_IPv6 instance=AS123456 remote-address=2803:cd60:6411:5::2 remote-as=64115 tcp-md5-key=peeringinperu max-prefix-limit=12000 max-prefix-restart-time=360 in-filter=PIT_PERU_sac_IPv6_IN out-filter=PIT_PERU_sac_IPv6_OUT remove-private-as=yes address-families=ipv6

Definējiet prefiksus, kurus plānojat paziņot

Šeit mums būs jāmaina LACNIC piešķirtie prefiksi un mēs to paziņosim kā / 22 un / 24s. IPv6 mēs par to pagaidām paziņosim tikai kā / 32.

/routing bgp network add network=100.100.100.0/22 synchronize=no
/routing bgp network add network=100.100.100.0/24 synchronize=no
/routing bgp network add network=100.100.101.0/24 synchronize=no
/routing bgp network add network=100.100.102.0/24 synchronize=no
/routing bgp network add network=100.100.103.0/24 synchronize=no
 
/routing bgp network add network=2803:cd10::/32 synchronize=no

Pārbaudiet darbību

Pārbaudiet BGP vienādranga statusu; ja tie darbojas, tiem ir jānorāda statuss Izveidots, ja ir rakstīts Connect vai Idle, tas nozīmē, ka kaut kas nav pareizi konfigurēts jūsu vai pakalpojumu sniedzēja pusē.

   /routing bgp peer print

Es ceru, ka šī rokasgrāmata palīdzēs jums viegli un droši iekļūt brīnišķīgajā BGP pasaulē.

BGP ierobežojumi Mikrotik RouterOS

Tā kā ir daudz jautājumu, es jums dalos ar RouterOS ierobežojumu sarakstu, vismaz tās versijā 6.x.x ar BGP

• Izmaiņas BGP filtros netiek atspoguļotas maršrutos, kas saņemti vai nosūtīti BGP vienādrangam. Lai to atrisinātu, var izslēgt un atkal ieslēgt attiecīgās ķēdes filtrus, ja tas nedarbojas, var mainīt filtru secību. Un atcerieties, ka ar BGP RouterOS ir jābūt pacietīgam, jo ​​tas ir tikai viena kodola process. Tas neietekmē pašu maršrutēšanu, taču ir svarīgi to pārbaudīt pēc izmaiņu veikšanas, lai pārliecinātos, ka tās ir veiktas.

• Tas nerāda reklāmu sarakstu Winbox GUI, un tas ir vēl viens labi zināms ierobežojums, veids, kā to atrisināt, ir atvērt termināli un ierakstīt komandu / routing bgp ads print

• Lēns konverģences laiks, jo RouterOS 6.x BGP ir viena kodola process un tāpēc nevar izmantot vairāku CPU kodolu priekšrocības.

• Iegūstot pilnu BGP tabulu (DFZ) no BGP vienādranga, ir ļoti lēni parādīt visus maršrutus Winbox GUI. Mans padoms ir izmantot regulāro izteiksmi un izmantot komandu / ip route print…, nevis skatīt maršrutus, izmantojot GUI.

• Šie punkti vispār nenozīmē, ka BGP ir kļūdains RouterOS, vienkārši jāiemācās sadzīvot ar šiem ierobežojumiem un paturēt tos prātā.